与 Pixelmator Pro 同步编辑

如果你在 Mac 上使用 Photomator,并已安装 Pixelmator Pro,就可以使用编辑同步功能,在两个 App 之间顺畅转移已编辑的照片,并利用各自独有的工具继续处理。例如,你可以在 Photomator 中编辑照片,然后将其发送到 Pixelmator Pro,添加文字、形状、绘画等内容。


将已编辑的照片分享到 Pixelmator Pro#

将已编辑的照片从 Photomator 导出到 Pixelmator Pro 时,裁剪、色彩调整、蒙版(masks)和透视校正(perspective corrections)等所有无损编辑(nondestructive changes)在 Pixelmator Pro 中仍可继续修改。

要将照片分享到 Pixelmator Pro,请执行以下任一操作:

  • 按住 Control 点按 Photomator 浏览器或胶片栏(filmstrip)中的照片,然后选择“使用 Pixelmator Pro 编辑”(Edit with Pixelmator Pro)。
  • 从屏幕顶部的“图像”(Image)菜单中选择 Image > Edit with Pixelmator Pro
  • 按键盘上的 Command ⌘ + Return ↵
  • 如果你编辑的是“照片”(Photos)中的图像,也可以使用“照片”中的 Pixelmator Pro 扩展打开它。

将已编辑的照片发回 Photomator#

要将图像分享到 Photomator,请执行以下任一操作:

  • 从照片浏览器(Photos browser)分享的图像: 从屏幕顶部的“文件”(File)菜单中选择 File > 修改“照片”中的原始照片(Modify Original in Photos)
  • 从文件浏览器(Files browser)分享的图像: 从屏幕顶部的 File 菜单中选择 File > 保存(Save)
  • 在“照片”的 Pixelmator Pro 扩展中保存已编辑的照片。
  • RAW 照片: 目前还无法将编辑后的 RAW 图像保存回 Photomator,但你可以选择 File > Save,将图像保存为 JPEG、HEIC 或 TIFF 文件格式,并勾选将编辑保存到附属文件(sidecar file)的选项。

打开使用 Pixelmator Pro 编辑的照片#

你可以像打开其他照片一样,重新打开在 Pixelmator Pro 中编辑过的照片。不过,Photomator 不支持 Pixelmator Pro 中的某些图层和编辑,例如形状、文字和剪贴蒙版。如果继续在 Photomator 中编辑这些照片,就需要将这些元素拼合(flatten)。

在 Photomator 中打开带图层的 Pixelmator Pro 文件时,有两个选项:

  • 拼合并编辑原始文件(Flatten and Edit Original): 合并所有不可编辑的图层,并覆盖原始图像。
  • 拼合并复制(Flatten and Duplicate): 创建原始图像的副本,其中包含所有不可编辑的图层,然后编辑拼合后的副本。

另请参阅#

浏览和管理照片

打开或导入照片

保存、分享和导出